Visibility into the FPGA.

Is EXOSTIV Dashboard always backward compatible with an IP generated with an older version?

Is EXOSTIV Dashboard always backward compatible with an IP generated with an older version?

No, not always.

At Exostiv Labs, we always try to maintain backward compatibility of the EXOSTIV Dashboard software with EXOSTIV IPs generated with former versions.

However, the development of new features sometimes forces us to change how we configure and communicate with our IP. In such a case there is no backward compatibility between our software and an EXOSTIV IP generated with a former version.

In such a case, there are 2 options:
– The older version of the software is still available and can be used.
– The EXOSTIV Dashboard project (.epf) file that contains the settings of IP has to be loaded into the new version of EXOSTIV Dashboard and the IP has to be generated and inserted again in the target design.

EXOSTIV IP must be re-generated in the following cases, due to a backward-compatibility break:
– When transiting from Dashboard version 1.7.x and older to Dashboard version 1.8.x

STAY IN TOUCH

Sign in to our Newsletter